Support

Forum

Forum

Anmeldung

Geben Sie Ihren Benutzernamen und Ihr Passwort ein, um sich anzumelden.

BUG: Verrechnung mit Kundenguthaben

halousi
Amateur
Themenersteller
Verfasst am: 14.02.2012 [18:27]
Hallo deltra,

uns ist gerade aufgefallen, daß ein vorhandenes Kundenguthaben beim erstellen der Rechnung aus dem Lieferschein nicht mehr verrechnet wird. Zumindest nicht im direkten Vorgang. Wenn ich aber auf dem Kontoauszug des Kunden nachsehe, wird der Betrag zwar verrechnet, die Rechnung bleibt aber als unbezahlt stehen. Wenn ich dann die Rechnung manuell auf "vollständig bezahlt" setze enstehen 2 Buchungen im Kundenkonto?

Lösche ich dann manuell die Zahlung im Vorgang und schließe anschließend die Rechnung werde ich endlich gefragt ob ich verrechnen möchte. Dann stimmt auch das Kundenkonto wieder.

Könnt Ihr das bitte mal prüfen?

Viele Grüße Der Zug fährt nur so schnell weil der Heizer so schwitzt!
Samm
orgaMAX-Profi
Verfasst am: 14.02.2012 [21:15]
In beiden Fällen werde ich gefragt, ob das Kundenguthaben mit der Rechnung verrechnet werden soll.
Bei Rechnung aus Lieferschein erstellen werde ich auch direkt gefragt. Sowie ich die offene Rg mit OK abschließen will, kommt diese Frage und wird dann bejaht auch auf vollständig bezahlt gesetzt. ۝ ➽► Du brauchst angepasste Vorlagen ? Hilfe per PM ◄ ۝
halousi
Amateur
Themenersteller
Verfasst am: 14.02.2012 [21:39]
Wie hast Du das Guthaben erzeugt? Per HBCI oder über das Verrechnungskonto? Ich habe es eben auf einer anderen Installation geprüft und habe dort das selbe Problem. Betrage wird auf dem Konto verrechnet aber ich werde weder gefragt noch wird der Status auf bezahlt gesetzt. Erst nach erneutem öffnen der Rechnung und anschließendem schließen über de OK-Button kommt die Frage und der Status wird korrekt gesetzt. Erzeugst Du die Rechnung und den Lieferschein in einem Vorgang aus dem Auftrag oder die Rechnung erst aus dem Lieferschein? Der Zug fährt nur so schnell weil der Heizer so schwitzt!
halousi
Amateur
Themenersteller
Verfasst am: 15.02.2012 [17:12]
... der Fehler ist heute wieder aufgetreten, siehe Screenshot icon_frown.gif Der Zug fährt nur so schnell weil der Heizer so schwitzt!
Dateianhang: Kundenguthaben.jpg
Samm
orgaMAX-Profi
Verfasst am: 15.02.2012 [17:54]
Ich kann nur nochmal auf meine Vorgehensweise verweisen.
Deine Formulierungen machen es mir nicht verständlich, wo Dein Problem sitzt.
Man ordnet ja immer noch selber den eingehenden Betrag einer offenen Rechnung zu ODER bei Schliessen einer Rechnung, wenn ein Guthaben des Kundenkonto vorliegt. ۝ ➽► Du brauchst angepasste Vorlagen ? Hilfe per PM ◄ ۝
halousi
Amateur
Themenersteller
Verfasst am: 15.02.2012 [18:17]
Hallo Samm,

ja - das ist mir schon klar. Allerdings kommt eben diese Frage "wollen Sie mit dem Guthaben verrechnen" eben nicht, bzw. erst wenn ich die Rechnung erneut öffne und dann wieder durch "OK" bestätige. Wie Du in dem Secreenshot sehen kannst wird der Betrag im Kundenkonte verrechnet, die Rechnung bleibt aber als "offen" stehen. Der Zug fährt nur so schnell weil der Heizer so schwitzt!
Samm
orgaMAX-Profi
Verfasst am: 15.02.2012 [18:29]
"halousi" schrieb:

Hallo Samm,

ja - das ist mir schon klar. Allerdings kommt eben diese Frage "wollen Sie mit dem Guthaben verrechnen" eben nicht...
bei welchen anders von mir genannten Situationen soll es denn ...?? ۝ ➽► Du brauchst angepasste Vorlagen ? Hilfe per PM ◄ ۝
halousi
Amateur
Themenersteller
Verfasst am: 15.02.2012 [18:39]
... wie meinst Du das? Der Vorgang ist: Auftrag am 13. per Webshop-Import anlegen, Zahlung geht ein und wird dem Kundenkonto zugewiesen. 2 Tage später kommt die Ware und wir erzeugen einen Lieferschein. Nachdem das Paket gepackt ist wird die Rechnung erzeugt, gedruckt und geschlossen und .... es kommt keine Frage nach einer Verrechnnung, obwohl Kundenguthaben vorhanden ist. Das ist der Vorgang. Alles weitere siehe Screenshot. [Dieser Beitrag wurde 3mal bearbeitet, zuletzt am 15.02.2012 um 19:48.]Der Zug fährt nur so schnell weil der Heizer so schwitzt!
Samm
orgaMAX-Profi
Verfasst am: 15.02.2012 [22:45]
Hallo!
Ja dann reden wir NICHT aneinander vorbei. Mit OK für'Rechnung schliessen' poppt das Fenster jedesmal auf, bis man die Entscheidung mit Kundenguthaben zu verbuchen bejaht.

Deine Konstellation am Screen: Konto ausgeglichen auf null und Rg offen läßt sich bei mir nicht produzieren. Übrigens es ist egal ob das Geld über offline Konto oder Kasse eingeht.

Also ein individuelles Problem, offensichtlich kommt das Fenster nicht bei dir: kein BUG in OM 12.00.00.119 ۝ ➽► Du brauchst angepasste Vorlagen ? Hilfe per PM ◄ ۝
halousi
Amateur
Themenersteller
Verfasst am: 16.02.2012 [07:41]
Guten Morgen Samm,

vielen Dank für Deine Mithilfe. Aber wenn es kein BUG ist, wie erklärt sich dann exakt der selbe Fehler auf einem 2. unabhängigen System (sogar mit anderer Seriennummer)? Zufall? Und, der Fehler tritt nicht sporadisch sondern immer und reproduzierbar auf.
Und, wie gesagt - wenn ich die Rechnung dann erneut öffne und wieder schließe frägt er plötzlich. Ich glaube da schon eher an einen BUG der irgndwie beim wandeln von LS zu RG und dem erstmaligen abspeichern die Meldung verhindert.

Möglichwerweise auch ein plattformabhängiges Problem - beide Stationen sind WinXP-Prof. Wir hatten mal ein anderes Problem, dass immer nur auf einem Win7 Rechner aufgetaucht ist.

Ich denke ich werde mich mal an den Support wenden.

Viele Grüße
halousi [Dieser Beitrag wurde 1mal bearbeitet, zuletzt am 16.02.2012 um 07:44.]Der Zug fährt nur so schnell weil der Heizer so schwitzt!

orgaMAX Forum hat 4547 registrierte Benutzer, 5468 Themen und 17977 Antworten.
Es werden durchschnittlich 6.1 Beiträge pro Tag erstellt.

Zur Zeit sind 0 Benutzer online, davon 0 registrierte Benutzer.
Heute war bereits 1 registrierter Benutzer online.

SUPPORT HOTLINE

Wir sind für Sie da!

+49 (0) 5231 7090-0

Montag - Freitag
8:00 - 12:00 und 13:00 - 18:00 Uhr